SUB2000 Bolt Head

#1

Anyone had this issue. I just recently picked up the gen 2 Sub 2000 and have ran around 200 freedom seeds through it and notice this while cleaning it…

1 Like
#2

Can you clue us in with a little more detail? What are you seeing?

3 Likes
#3

@Baker519 If you are talking about rub marks from the bolt tube I have the same thing and I would say that is normal.

6 Likes
#4

Apply grease liberally and keep clean

4 Likes
#5

Sorry folks it’s kinda hard to see in the pic. It appears to be cracked

2 Likes
#6

Might be completely fine I just can’t remember if it was there before I tore it apart to lube it up and add all it’s upgrades. I’d rather ask here and make sure. I had a friend check his and he didn’t have that crack/gash… thanks in advance

2 Likes
#7

I just checked mine and I don’t have anything like that either. IMO, that part needs replacing ASAP.

2 Likes
#8

Ugh, what caliber is it?
https://www.keltecweapons.com/rifles/sub-2000

2 Likes
#9

It’s 9mm. Wanted a 40 but couldn’t find one.

3 Likes
#10

I completely agree. I’ll get ahold of Kel-Tec on Monday.

2 Likes
#11

Send it back to KelTec. All my KelTec’s have required visits home to Momma.

3 Likes
#12

Same here. I’ve never had a single Kel-Tec that was 100%. In fact, I swore them off completely for 10+ years. Then I saw the Gen 2 SUB2000 and had to have one. I thought I got lucky because it was accurate and functioned flawlessly. I was quite pleased with it and then…BOOM… The recall notice dropped and it had to go back. :roll_eyes:

2 Likes
#13

I called them today and no questions asked they just said ship the part back and they will ship a replacement… I was hoping that after I replaced every other part inside of it would be reliable. My hunt for a truck gun continues.

2 Likes
#14

Well, now you’re replacing this part and it should be good. I’ve never seen or read about another failure like that.

1 Like
#15

I think that’s a one off issue, I’m definitely keeping an eye on mine but keltec is pretty good about making things right so I can’t really complain.

2 Likes
#16

James, are you using any type of + P Loads or hot, hot loads that would cause this ?
If you bought your Sub 2k new then you should be under warranty. After reading all these replies and asking Chris, I would be making a phone call down to Cocoa and see about shipping it down there for some warranty work.

3 Likes
#17

He already did that and said they’d replace the part(s). I have about 150 +p rounds of my pistol carry ammo through my SUB2000 with zero issues. I wanted to make sure it would run that ammo reliably just in case.

2 Likes
#18

I see that, I replied before reading all the way down, sorry about that.

3 Likes
#19

No worries. :grinning:

2 Likes
#20

I’ve ran all my carry ammo through s2k flawlessly, I think it’s just a fluke in the metal, keltec will make it right :blush:

3 Likes